VKontakte.DJ
forum traveling
 

Celestial Software

...better by design

Home Support SSH Client Forums
Welcome, Guest
Please Login or Register.    Lost Password?
Installation problem (1 viewing) (1) Guest
Go to bottom Favoured: 0
TOPIC: Installation problem
#352
Installation problem 15 Years, 5 Months ago  
I'm trying to put version 3.11 (or the latest) onto a new computer.
I've used the software for ages on the old one.
I have Windows XP Pro with SP 2 and all the updates installed. I also have Avast anti-virus installed.
When I click on the Absolute.exe to install I get an initial box asking me if it's ok to install it. When I click yes, a new window flashes up for an instant but then vanishes and nothing else happens.
This happens with both 3.11 and 3.13 and when I pause Avast and disable window's firewall.
Help- I need to install quickly!
Thanks.

[ October 19, 2004, 08:24 AM: Message edited by: Brian T. Pence ]
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#353
Re: Installation problem 15 Years, 5 Months ago  
Any chance of a reply?
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#354
Re: Installation problem 15 Years, 5 Months ago  
Stuart, there's a bug in the installer (InstallShield) that can cause something like this. The solution has always been to reboot and install the software first before you run other stuff.

Let me know if this helps.

Brian
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#355
Re: Installation problem 15 Years, 5 Months ago  
It doesn't Brian, I'm afraid.
I even went into the task manager and closed every application I could.
So I have Windows XP Pro with SP2 installed and I can't get the latest version of Absolute Telnet to install.
I would very much appreciate some help because the only reason my old computer is still up and running is because I need it to Telnet.
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#356
Re: Installation problem 15 Years, 5 Months ago  
Stuart,

Closing the other apps isn't good enough. There's some resource that InstallShield needs that can only be freed by a reboot. I've never been able to pinpoint precisely what InstallShield's problem is, but a reboot should always work.

Brian
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#357
Re: Installation problem 15 Years, 5 Months ago  
Tried that Brian with no difference.

I think the only way this is going to work is if you can rebuild the app using a new (working) version of Installshield. Or something better.
Is that possible?
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#358
Re: Installation problem 15 Years, 5 Months ago  
Brian I appreciate it's not your responsibility to fix problems on other people's computers.
But this is a brand new top-specification PC with a fresh install of XP SP2 and about 30 other applications without any problems.
I really think this is an issue with the installation software you are using.
I even booted into safe mode and tried installing and it made no difference.

[ October 25, 2004, 04:19 AM: Message edited by: Stuart Wright ]
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#359
Re: Installation problem 15 Years, 5 Months ago  
Stuart, I KNOW for a fact it is an installshield problem. Switching to another installer *is* the solution, but not one to be taken lightly.

Meanwhile, I'll try to do some more research on this. If you could, please try the new beta. I'm not sure if it'll be more successful for you, but it's worth a try.

http://www.celestialsoftware.net/telnet/AbsoluteTelnetBeta.exe

Brian
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#360
Re: Installation problem 15 Years, 5 Months ago  
Hi Brian, you sound upset.
Sorry if my post upset you. I was just trying to clarify the situation for you.
Having 20 years experience programming computers and having experienced Install Shield once, I know that doing a new exe build is a timely and potentially expensive exercise.
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#361
Re: Installation problem 15 Years, 5 Months ago  
Stuart,

I've found a bunch or references to this issue, but no solution. Some references refer to a problem with Outlook, so make sure that you're not running Outlook (or any MS apps such as Office, Office quicklaunch bar, media player, etc)

All of the theories on this problem point to *SOME* other product not allowing the 16bit installer to run. The real problem is that it's probably not only just one culprit in all cases, so it's hard to point to a solution that always works.

Perhaps I can write a small test app that will try to identify the offending application so you could terminate it.

I'll be looking into this more...
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#362
Re: Installation problem 15 Years, 5 Months ago  
Stuart,

I've found one possible solution (finally). There might be a way to rig the install to bypass the 16bit portion.

The 16bit installer stub is a throwback to the Win31 days. Its purpose is to detect the OS version, then run the appropriate install depending on whether you're running on 16bit or 32bit windows. This 16bit stub is where I suspect the hang to occur. It's really an unnecessary step and there may be a way to call the 32bit installer directly, but I'll have to do some testing before I make this change.

One drawback of the proposed solution is that the install would have to be run from a place where you have write permission. While generally not a problem if you've downloaded from the internet, this could cause a problem if you burn the installer to CD, for example. The issue is that with the proposed soultion, the installer will try to unpack itself into a subdirectory in the same directory where it is run. If run from CD, this is not possible and the install will fail.

While not a permanent solution, this may at least get you past your particular problem quickly. I'll let you know when I have something to test.
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#363
Re: Installation problem 15 Years, 5 Months ago  
Brian that would very much be appreciated.
Only today my server started slowing down and I would normally use Telnet to log in and restart Apache.
I had to email the support staff and ask them to do it.
Many thanks.
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#364
Re: Installation problem 15 Years, 5 Months ago  
bhpence (User)
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#365
Re: Installation problem 15 Years, 5 Months ago  
That worked just fine, thanks, Brian.
I have emailed you asking for a new unlock email as I can't find the previous one.
Many thanks.
Spinball (User)
Fresh Boarder
Posts: 8
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#366
Re: Installation problem 15 Years, 4 Months ago  
FYI I am having the same problem with the the newest release of Absolute Telnet,

My notebook crashed on Sunday and I've had to completely reinstall all of my software. I am running WinXP SP2 and am getting this error when I try to install Absolute Telnet.

**********************************************
16 bit MS-DOS Subsystem : Command Prompt - edit autoexec.nt
C:WINDOWSSYSTEM32AUTOEXEC.NT. The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose 'Close' to terminate the application.
**********************************************

the release canidate that you posted in this post did install But it is out of date and I cant use it. I have my License file handy

any way to help.

Thanks
logan-7 (User)
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
Bill
What is put out come's back 10 fold
 
The administrator has disabled public write access.  
#367
Re: Installation problem 15 Years, 4 Months ago  
William,

The problem you are having is becoming a more common one. Your autoexec.nt is missing for some reason. Do a search for it on your computer and if you find it, move it back to c:windowssystem32. If you can't find it, you'll have to expand it off of your CD or find a copy on the internet somewhere.

There is a lot of speculation of why autoexec.nt files are going missing. Suspects range from adware to a virus to a Microsoft support patch gone bad. Nobody's really been able to nail it down just yet. It's not an AbsoluteTelnet issue exactly. It's a system-wide problem with the 16-bit subsystem within Windows.

Normally, this wouldn't affect AbsoluteTelnet, because it is a 32-bit application. However, the version of the installshield installer that I use is a 16-bit app and won't run if autoexec.nt is gone. The installer mentioned in this post was a test to see if I could get InstallShield to run in 32-bit mode (for a different reason). The install ran ok, but is not my longer-term solution.

Currently, I'm working on a 32-bit install solution using another product (Inno Setup: www.innosetup.com). For now, just locate your autoexec.net file and place it back where it goes.
Then, run the install for 3.50.

Brian
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#368
Re: Installation problem 15 Years, 4 Months ago  
That did the trick,

Thanks
logan-7 (User)
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
Bill
What is put out come's back 10 fold
 
The administrator has disabled public write access.  
#369
Re: Installation problem 15 Years, 4 Months ago  
I'm running XP pro SP2 and i have the autoexec.nt file on my system32 directory. Even after a fresh reboot i cannot install the 3.50 version . Please help! Your upgrade notification is annoying me :D

Thanks in advance,

Patrick
patrick (User)
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#370
Re: Installation problem 15 Years, 4 Months ago  
Patrick,

Which error are you getting specifically? One of the side-effects of the autoexec.nt file problem is that it will often be removed AGAIN when you reboot.

Brian
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#371
Re: Installation problem 15 Years, 4 Months ago  
the autoexec is not removed after reboot. Its still there. And i dont get an error message. I see the first unpacking stage of installshield and then nothing happens. Even after a fresh reboot. Anyway when i try to shutdown my computer after this, it's complaining about some 16 bits application not shutting down or something.

Thanks,

Patrick
patrick (User)
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
35
 
The administrator has disabled public write access.  
#372
Re: Installation problem 15 Years, 4 Months ago  
I've developed a new install procedure using a different product (InnoSetup) instead of the old version of InstallShield I was using. The benefits are:

1. Smaller package - a full 1 Meg smaller than installShield. Installation file went from 3.3Meg to 2.3 Meg.

2. Faster, fewer prompts

3. Fully 32-bit - Eliminates installation 'hangs', 'autoexec.nt' problems, and other problems with the 16-bit Windows subsystem

4. InnoSetup is FREE and easy to use!!! Very cool for shareware developers...

http://www.celestialsoftware.net/telnet/AbsoluteTelnet3.61.exe

AbsoluteTelnet Version 3.61 is the first version to be released with InnoSetup. As this process is still new, there MAY be other issues introduced by this product that will still have to be addressed. However, I've tested it with good results under Win98(English, Japanese, Korean, and Chinese Traditional), Win2000, XP Home, and XP Pro.

If you have any issues or problems with the new install, please let me know!!! The first time your run it, you'll get two ugly popup message boxes that describes how it's going to uninstall the prior (InstallShield) version. Ignore this message box, it will be gone in a future version and is mainly there for verification and testing.

Enjoy!

Brian
bpence (Admin)
Admin
Posts: 1340
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
Go to top